Startpagina > Legacy Software (V6 and older) > General Errors > Error: [BlockDB.update] Failed to insert row into bptree

Error: [BlockDB.update] Failed to insert row into bptree

Operating system

All

Software

All

Error Message

[BlockDB.update] Failed to insert row into bptree...

Cause

This error occurs when there is a issue with the index. There are various index files this van relate to depending on the software version and destination.
  • Temporary index created during the backup process.
  • Online index on the backup server.
  • Local index of a local copy.

Solution

Temporary index
The temporary index is created in the temporary directory chosen in the backupset. It might happen that the disk has run out of space stopping the software from updating the index or antivirus can do a scan on the file locking access to it.
This index can be recognized by the path of the temporary directory in the error message about the index file:

V6: C:\TemporaryBackupData\1479106745060\index.bdb
V7: C:\TemporaryBackupData\1479106745060\OBS@100\index.b2b

Online index
There is difference between V6 software and V7 software:
For V6 you will need to contact the support department so they can fix the issue.
For V7 you can execute the index check yourself using the software client on the PC.

Local index
There is difference between V6 software and V7 software:
For V6 you can use the index corrupted article to solve the issue.
For V7 you can use the same index check as for the online check. You only need to use the local copy destination instead of the backup server during the selection process.

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