Error 0x800423f4

OS

Windows 2008 (R2)

Software

5.5.5.0 and higher

Error message

Volume Shadow Copy Error 0x800423f4 - writer error: non retryable

Cause

It is caused when you use VSS in your backup and have one or more of your SQL databases running in non-simple recovery mode, even if you are not backing them up at the time.

Solution

Option 1
Try restarting the Volume Shadow copy service using a pre-backup command:
  1. Create a batch file with the following commands in it
    • net stop vss
    • net start vss
  2. Open the software
  3. Go to the backupset settings under the cog
  4. Open the "Command Line Tool" tab
  5. Add the batch file as a Pre-backup commando (don't forget to set the working dir)

Option 2
Microsoft have documented the error in this article - http://support.microsoft.com/?id=828481 and released a hotfix (also included in Windows 2003 sp1). However, while this will make your backups successful, the copy of SQL in your back-up will be corrupted and not available for restore.

Option 3
Change your SQL databases to simple, by using the SQL Manager. You simply find the databases (Microsoft SQL Servers > SQL Server Group > SERVERNAME > Databases). Right click and choose the properties on each database.
On the Options tab, change the Recovery Mode from "Full" to "Simple". This essentially turns off up-to-the-minute restore (ie no log files). NTBackup/WBAdmin will successfully backup your SQL databases, and will be able to restore it up to the time of the backup (which is pretty consistent with the rest of the SBS server). Unfortunately though, you will not be able to recover up to the minute of the failure. This is by far the easiest to configure.

Option 4
Move your SQL databases to a volume that is not included in the backup. It has to be a separate volume all together (not just a removed folder) since NTBackup/WBAdmin evokes VSS writers based on what applications are installed on that volume. You can then use the SQL backup tools in the SQL enterprise manager to backup the SQL databases to a volume that 'is' included in the backup, and then backup the backup files from the SQL backup. This of course makes the recovery of SQL somewhat time consuming.
If none of the above works, try re-registering the VSS dll's using the RegisterVSS.bat file in C:\Program Files\Mindtime Pro Backup\bin.
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