VSS_WS_FAILED_AT_*

OS

Windows 2008 and higher

Software

5.5.7.2 and higher

Error message

  • VSS_WS_FAILED_AT_PREPARE_BACKUP
  • VSS_WS_FAILED_AT_FREEZE
  • VSS_WS_FAILED_AT_PREPARE_SNAPSHOT
  • VSS_E_WRITERERROR_TIMEOUT

Cause

This error can occurs if one of the following conditions are met:
  • There is a problem with the Volume Shadow Copy service.
  • Circular logging is enabled for the mailbox store selected for backup.
  • For server with MS SharePoint Foundation 2010 Service Pack 1 or Windows SBS 2011, the service pack update process maybe incomplete.
  • For server with MS SQL, there maybe conflict with the SQL Server VSS Writer service.
  • If this message occurs a lot it might indicate a underlying hardware issue or a lack of resources (e.g. not enough RAM)

Solution 1

Exchange 2010 has several new backup types:
  • Full: Database backup, cleans up the logs.
  • Copy: Database backup, does not clean up the logs.
  • Differential: LOG backup, does not clean up the logs.
  • Incremental: LOG backup, cleans up the logs.
The most reliable way of making a backup is the database backup.
Set the daily schedule to full. Optional change the in-file-delta settings to create a weekly differential.

Solution 2

Open the Event Viewer snap-in on the affected machine, under the 'Application' tab, check for any Volume Shadow Copy error at the time of the backup.
- Check on the VSS writers, open an Administrative command prompt and enter the following commands:

>vssadmin list writers

This should output a list of writers and their status, they should all be reported as stable. If there is writer listed at unstable, please re-register the Volume Shadow Copy Service by following the instructions below:
  • Execute the script C:\Program Files\Mindtime Pro Backup\bin\RegisterVSS2010.bat (Pre 6.11.0.0 Software: RegisterVSS2010.zip).
  • Manually reboot the machine
In case this does not help
Try cleaning up the VSS snapshots on the affected server:
- Open an administrative command prompt and enter the following commands:

>vssadmin delete shadows /all

On some systems, the command 'vssadmin delete shadows' may not be available. For these cases, open an administrative command prompt and enter the following commands:

>vssadmin Resize ShadowStorage /For=C: /On=C: /MaxSize=300MB

If there is no VSS writer error shown, but the system is not creating a new VSS snapshot, you may have to actually increase the max shadow storage size on your system. Open an administrative command prompt and enter the following commands:

>vssadmin Resize ShadowStorage /For=C: /On=C: /MaxSize=10GB

Circulair logging
Check if circular logging is enabled for the corresponding information store. If it is, try disabling the circular logging option and restart the "Microsoft Exchange Information Store" service afterward.
Perform a full MS Exchange server backup instead of transaction log backup straight after disabling circular logging. This would ensure that the data on server are all backed up properly.

Sharepoint
Administrator can also run the following commands to determine if you need to complete the update process with PSCONFIG:
- Launch an administrative SharePoint 2010 management shell and enter the following commands:

>(get-spserver $env:computername).NeedsUpgrade

If the result of this command is TRUE, please complete the update process with PSCONFIG.
For instruction, please refer to the Official SBS Blog.
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