Scheduler service problems

OS

Windows, Linux, Mac

Error message

The scheduled backup does not start
Backup is missed

Cause

There are a number of things that can cause a backup to be missed as can be read in the following article: Backup missed.
One of which is that the scheduler service isn't working/hasn't started.

Solution

In most cases regardless of the OS, (re-)installing the latest software version also installs a clean version of the scheduler service with the correct settings.
In case that does not solve the scheduler issue the following steps should help identify the problem.
On every OS the software the same steps that have to be checked:
  1. Install a scheduler service
  2. Create a locale profile with the settings (.obm)
  3. Link the profile to the scheduler service (stored in home.txt)
  4. Start the scheduler service
Now to check if any of the above has failed:
  1. Check if the local profile directory is created
    • No?: Open the software and login, this should create the .obm directory
  2. Check if the profile is linked to the scheduler
    • No?: Manually enter the path to the .obm directory
  3. Check if the scheduler service is installed/present on the system
    • No?: Re-install the latest software
  4. Check if the scheduler service is started
    • No?: Manually start the service and check if it is set to start at boot.
  5. Check the las modified date and content of the scheduler log which should be no older than 5~10 minutes
    • Any of the above steps should have solved the problem by now.
    • if not, please contact support

 

Windows
Profile location C:\users\[user]\.obm
Scheduler log C:\users\[user]\.obm\log\Scheduler\debug.log
Scheduler Process Task Manager > Details tab > bschJW.exe
Software/Backup Process Task Manager > Details tab > bJW.exe
Profile link C:\ProgramData\MindtimeProBackup\home.txt
Scheduler service name* Mindtime Pro Backup Services
* This is the name of the Windows service that starts the backups, Start > Execute > services.msc
 
Linux
Profile location ~/.obm
Scheduler log ~/.obm/log/Scheduler/debug.log
Scheduler Process ps -ef | grep bschJW
Backup Process ps -ef | grep bin/java
Profile link* /usr/local/obm/home.txt
Scheduler service name obmscheduler
* Assumption: The software is installed in /usr/local/obm
 
Mac
Profile location ~/.obm
Scheduler log ~/.obm/log/Scheduler/debug.log
Profile link /Applications/MindtimeProBackup.app/home.txt
Scheduler Process ps -ef | grep java
Software/Backup Process ps -ef | grep Mindtime
(Het proces zonder Java in de parameters)
Scheduler service name ls /Library/LaunchDaemons | grep Mindtime
Scheduler service stop sudo launchctl unload /Library/LaunchDaemons/com.MindtimeProBackup.scheduler.plist
Scheduler service start sudo launchctl load -w /Library/LaunchDaemons/com.MindtimeProBackup.scheduler.plist
 
Synology NAS
Profile location /volume1/@appstore/MindtimeProBackup/.obm
Scheduler log /volume1/@appstore/MindtimeProBackup/.obm/log/Scheduler
 
QNAP
Profile location* /share/CACHEDEV1_DATA/homes/admin/.obm
Scheduler log /share/CACHEDEV1_DATA/homes/admin/.obm/log/Scheduler
* The CACHEDEV1_DATA part of the path can vary depending on your RAID configuration
BENELUX GERMANY AUSTRIA / SWITZERLAND
+31 (0) 570 56 23 43 +49 (0) 800 12 22 587 +31 (0) 570 71 43 06
info@mindtimebackup.nl info@mindtimebackup.de info@mindtimebackup.de